tadgallery 圖片跑馬燈及相片輪播無法顯示

1 xranger 網友
14年7月8日 16:37
轉送到...
蓮姐您好:第一次在這裡發問,主要是想用tadgallery的功能區塊時,會出現下列警告訊息view.php?sn 後沒有連結的圖片號碼,不知是甚麼原因??之前使用是正常的,可是後來裝了tadgallery 3.3版出現mysql錯誤後,又裝回tadgallery 2.01版,就開始不正常了。

警告:無法連接到 http://192.168.0.199/html/modules/tadgallery/view.php?sn
2 睡蓮 網主
14年7月8日 22:35
轉送到...
我沒有 2.01 版可測,剛測了 3.3 版在部分佈景下啟用區塊後可跑,view.php?sn後有連結的圖片號碼。請問您用的是什麼區塊呢?
請問您出問題的 tadgallery 是升級而來的,還是反安裝舊模組,全新裝新版的?
無論升級或全新安裝,之後有沒有到系統下的維護清除快取?
請問 XOOPS 版本?PHP 及 MySQL 版本?tadtools 版本?用啥佈景?
3 xranger 網友
14年7月9日 14:53 14年7月9日 15:15
轉送到...
蓮姐好:
我的tadgallery是用升級的方式覆蓋舊模組後更新,更新完有進維護清除快取,並且重新輸出樣版檔,使用的PHP 5.2.6版,MYSQL 5.0.5lb版,XOOPS 2.5.5版,佈景為內建的suico,tadtools 2.54版。如果升級到tadgallery 3.3版,出現You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'by post_date desc limit 0 , 10' at line 1,就進不了首頁,只能再用2.01版覆蓋後還原。
4 睡蓮 網主
14年7月10日 0:26
轉送到...
You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'by post_date desc limit 0 , 10' at line 1 是 jGrowl 動態訊息提示裡面秀出來的字句而不是頁面底下秀出的除錯訊息吧?情況就跟此篇問題類似,都是由 2 升到 3 版後出現區塊設定值問題,故您在升級 tadgallery 之後也請將有啟用的相關區塊裡面的所有設定值重設一下,尤其是某些區塊在升級前原有的設定值會於升級後變為空值,因此請先去設一設吧。
5 xranger 網友
14年7月10日 13:41
轉送到...
蓮姐好:
妳PO的那篇文章我有進去看了,可是我只有開兩個區塊,一個是相片跑馬燈,一個是相片投影秀,裡面沒有太多要我設定的地方,我把圖抓下來了,再麻煩蓮姐幫忙看看,感恩。 隱藏內容
6 睡蓮 網主
14年7月10日 20:33
轉送到...
雖然我沒有 2.2 版
但我在多個測試站中找到 2.0 版本的
就將它裝到 2.55 測試站去
後用 3.3 版覆蓋過去
更新模組及清除快取後
總算試出問題所在了

您看看下面附圖
圖一 before.gif是升級前的區塊資料表裡的 tadgallery 區塊列表
圖二 after.gif是升級後的
您從圖二中看出問題在哪裡嗎?
您到 phpmyadmin 資料庫看看您的 ****_newblocks 資料表下是不是也像圖二一樣有重複
( 但同一區塊其選項值有不同例如舊的用 order by rand() 而新的用 rand )
若看到有一樣的重複問題
您便要手動刪除舊版本的那幾列( 新舊看 bid 號碼)(刪前請先備份)
刪除之後網站頁面之升級前的舊區塊會不見了
您到後台區塊管理下去啟用升級後的新區塊看看是不是正常回來 隱藏內容
7 xranger 網友
14年7月11日 11:23
轉送到...
蓮姐好:
應該是這個問題造成的,因為我還是區隔不太出來新版或舊版的去刪除,只好把所有newblock中的tadgallery都刪除掉,然後去更新模組重建區塊,再去重建樣版和維護清快取,它終於又正常了,謝謝蓮姐百忙之中還要幫我們做測試和解答,這樣有很多可能相同問題造成的,又多了一個解決的方式,真好。